文档信息:https://ai.qq.com/doc/nlpchat.shtml

自行申请APPkey,使用效果如图:

QQ截图20200419143015.png

代码如下:

.版本 2

.子程序 _按钮1_被单击
.局部变量 appid, 文本型
.局部变量 nonce_str, 文本型
.局部变量 question, 文本型
.局部变量 session, 文本型
.局部变量 time_stamp, 文本型
.局部变量 appkey, 文本型
.局部变量 url, 文本型



appid = 编辑框_appid.内容
nonce_str = 文本_取随机字符 (16)
question = 编辑框_文本.内容
session = “10000”
time_stamp = 时间_到时间戳 (, 真, 真)
appkey = 编辑框_appkey.内容



url = “app_id=” + appid + “&nonce_str=” + nonce_str + “&question=” + 编码_URL编码 (question, 真, 真) + “&session=” + session + “&time_stamp=” + time_stamp + “&app_key=” + appkey + “&sign=” + 计算sign (appid, nonce_str, question, session, time_stamp, appkey)

编辑框1.内容 = gotalk (url)



.子程序 计算sign, 文本型
.参数 appid, 文本型
.参数 nonce_str, 文本型
.参数 question, 文本型
.参数 session, 文本型
.参数 time_stamp, 文本型
.参数 appkey, 文本型
.局部变量 url, 文本型
.局部变量 sign, 文本型

url = “app_id=” + appid + “&nonce_str=” + nonce_str + “&question=” + 编码_URL编码 (question, 真, 真) + “&session=” + session + “&time_stamp=” + time_stamp + “&app_key=” + appkey
sign = 校验_取md5 (到字节集 (url), 真, )
返回 (sign)


.子程序 gotalk, 文本型
.参数 url, 文本型
.局部变量 文本, 文本型
.局部变量 JSON, 类_json
.局部变量 talk, 文本型

文本 = 编码_URL解码 (网页_访问S (“https://api.ai.qq.com/fcgi-bin/nlp/nlp_textchat”, 1, url, , , , , , , , , , , , , , , , , , ), 真)
JSON.解析 (文本)
talk = JSON.取通用属性 (“data.answer”, )

返回 (talk)

下载地址:https://ipad.lanzous.com/ibldswf

最后修改:2020 年 04 月 19 日 02 : 44 PM